Invoice approval functionality is temporarily not available
Incident Report for Tradeshift
Resolved
This incident has been resolved.
Posted Jan 23, 2023 - 11:34 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 23, 2023 - 09:29 PST
Investigating
The Invoice approval functionality is temporarily not available. We are currently investigating the issue.
Posted Jan 23, 2023 - 08:12 PST
This incident affected: WebUI ( go.tradeshift.com ).