Delayed processing of documents
Incident Report for Tradeshift
Resolved
We’re back! We’re sorry for the disruption to your day
Posted Feb 03, 2020 - 09:53 PST
Investigating
We are investigating delays on document processing.

We apologize for the inconvenience.
Posted Feb 03, 2020 - 08:16 PST
This incident affected: Tradeshift Go (getgo.tradeshift.com), WebUI ( go.tradeshift.com ), API ( api.tradeshift.com ), and Integration ( FTP/FTPS/SFTP ) ( si.tradeshift.com ).