Degraded performance
Incident Report for Tradeshift
Resolved
We’re back! We’re sorry for the disruption to your day
Posted about 1 month ago. May 13, 2019 - 13:05 PDT
Investigating
We are investigating performance problems with the platform
Posted about 1 month ago. May 13, 2019 - 11:06 PDT
This incident affected: WebUI ( go.tradeshift.com ) and API ( api.tradeshift.com ).