Delayed document processing

Incident Report for Tradeshift

Resolved

This incident has been resolved.
Posted May 06, 2025 - 10:36 PDT

Investigating

Some customers might experience delays in the document processing. The Tradeshift team is investigating.
Posted May 06, 2025 - 08:36 PDT