Degraded performance
Incident Report for Tradeshift
Resolved
Response times are back to normal.
Posted Jul 13, 2017 - 04:10 PDT
Monitoring
We are seeing elevated response times for some operations and monitoring the situation to get them back to normal.
Posted Jul 13, 2017 - 02:59 PDT