Degraded performance
Incident Report for Tradeshift
Resolved
This incident has been resolved.
Posted Jun 23, 2023 - 04:24 PDT
Update
We are continuing to monitor for any further issues.
Posted Jun 23, 2023 - 00:03 PDT
Update
The fix implemented yesterday addressed the significant performance issue. However, we continue to investigate the need for additional optimization measures.
Posted Jun 22, 2023 - 02:36 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 21, 2023 - 09:57 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 21, 2023 - 05:47 PDT
Investigating
We are investigating performance problems with the platform
Posted Jun 21, 2023 - 01:22 PDT
This incident affected: WebUI ( go.tradeshift.com ) and API ( api.tradeshift.com ).