Delayed processing of documents
Incident Report for Tradeshift
Resolved
We’re back! We’re sorry for the disruption to your day
Posted 30 days ago. Sep 23, 2019 - 03:30 PDT
Investigating
We are investigating delays on document processing.
Posted 30 days ago. Sep 23, 2019 - 01:03 PDT
This incident affected: General availability, WebUI ( go.tradeshift.com ), API ( api.tradeshift.com ), and Integration ( FTP/FTPS/SFTP ) ( si.tradeshift.com ).