Degraded performance

Incident Report for Tradeshift

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 04:58 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2025 - 03:39 PDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 01, 2025 - 03:37 PDT

Update

We are investigating delays on document processing.

We apologize for the inconvenience.
Posted Apr 01, 2025 - 00:52 PDT

Identified

The issue has been identified and an improvement will be planned & applied.
Posted Mar 31, 2025 - 22:49 PDT

Investigating

We are investigating performance problems with the platform
Posted Mar 31, 2025 - 18:46 PDT
This incident affected: Tradeshift Go (getgo.tradeshift.com), WebUI ( go.tradeshift.com ), API ( api.tradeshift.com ), and Integration ( FTP/FTPS/SFTP ) ( si.tradeshift.com ).