Sandbox: WebUI unavailable
Incident Report for Tradeshift
Resolved
This incident has been resolved.
Posted Feb 13, 2020 - 06:50 PST
Identified
sandbox.tradeshift.com is currently unavailable - we're investigating
Posted Feb 13, 2020 - 06:44 PST
This incident affected: Sandbox ( sandbox.tradeshift.com ).