Delayed processing of documents
Incident Report for Tradeshift
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 13:23 PST
Monitoring
The issue has been identified and multiple fixes applied. Minor problems might still appear for the next 2-4 hours.
Posted Feb 19, 2024 - 19:36 PST
Investigating
We are investigating delays on document processing.

We apologize for the inconvenience.
Posted Feb 19, 2024 - 11:30 PST
This incident affected: Tradeshift Go (getgo.tradeshift.com), WebUI ( go.tradeshift.com ), API ( api.tradeshift.com ), and Integration ( FTP/FTPS/SFTP ) ( si.tradeshift.com ).