Delayed processing of documents
Incident Report for Tradeshift
Resolved
This incident has been resolved.
Posted Nov 16, 2023 - 21:37 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2023 - 08:49 PST
Update
There will be limited availability to the platform for up to 1 hour due to emergency maintenance. Emergency maintenance starts at 14:00 UTC.
Posted Nov 16, 2023 - 05:52 PST
Investigating
We are investigating delays on document processing.

We apologize for the inconvenience.
Posted Nov 15, 2023 - 10:15 PST
This incident affected: WebUI ( go.tradeshift.com ) and API ( api.tradeshift.com ).