Sandbox WebUI unavailable
Incident Report for Tradeshift
Resolved
We’re back! We’re sorry for the disruption to your day
Posted 3 months ago. May 26, 2019 - 12:51 PDT
Identified
sandbox.tradeshift.com is currently unavailable - we're investigating
Posted 3 months ago. May 26, 2019 - 12:45 PDT
This incident affected: WebUI ( go.tradeshift.com ) and Sandbox ( sandbox.tradeshift.com ).