Delay in sending emails
Incident Report for Tradeshift
Resolved
This incident has been resolved.
Posted Dec 14, 2023 - 05:00 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 14, 2023 - 04:02 PST
Investigating
We are currently experiencing a delay in sending a large volume of outbound emails, we are working to correct this shortly.
Posted Dec 14, 2023 - 01:52 PST
This incident affected: WebUI ( go.tradeshift.com ).