Degraded UI performance
Incident Report for Tradeshift
Resolved
This incident has been resolved.
Posted Jun 20, 2022 - 12:13 PDT
Monitoring
The root cause has been identified and actions have been taken to remedy the situation. Performance is back to normal. We're still monitoring the situation.
Posted Jun 20, 2022 - 08:24 PDT
Investigating
We are currently investing degraded performance of the Tradeshift platform and UI.
Posted Jun 20, 2022 - 07:23 PDT
This incident affected: WebUI ( go.tradeshift.com ).