Degraded performance
Incident Report for Tradeshift
Resolved
This incident has been resolved.
Posted about 2 months ago. Apr 29, 2019 - 04:14 PDT
Investigating
We are investigating performance problems with the platform
Posted about 2 months ago. Apr 29, 2019 - 03:20 PDT
This incident affected: General availability, WebUI ( go.tradeshift.com ), and API ( api.tradeshift.com ).