Delay in processing emails
Incident Report for Tradeshift
Resolved
Our email processing queue is back to normal. If you experience any issues, please contact support.
Posted Jul 28, 2022 - 01:28 PDT
Monitoring
We are currently experiencing a delay in processing a large volume of outbound emails, we are working to correct this shortly.
Posted Jul 28, 2022 - 00:54 PDT
This incident affected: WebUI ( go.tradeshift.com ).