Platform unavailable
Incident Report for Tradeshift
Resolved
We are back to normal.
Posted Jul 13, 2017 - 02:56 PDT
Identified
Problem has been identified and we are working to restore functionality.
Posted Jul 13, 2017 - 02:41 PDT
Investigating
We are investigating a service outage at Tradeshift Platform right now.
Posted Jul 13, 2017 - 02:35 PDT