Sending documents on sandbox is currently delayed.
Incident Report for Tradeshift
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 18, 2019 - 08:29 PDT
Update
The issue has been resolved and documents should be flowing as expected.
Posted about 1 month ago. Sep 18, 2019 - 08:29 PDT
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Sep 18, 2019 - 08:08 PDT
This incident affected: Sandbox ( sandbox.tradeshift.com ).