Platform unavailable
Incident Report for Tradeshift
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 27, 2019 - 06:30 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 4 months ago. Jun 27, 2019 - 02:25 PDT
Investigating
We are currently investigating an issue with the platform
Posted 4 months ago. Jun 26, 2019 - 23:54 PDT
This incident affected: Sandbox ( sandbox.tradeshift.com ).