Degraded performance
Incident Report for Tradeshift
Resolved
This incident has been resolved.
Posted Apr 12, 2021 - 10:27 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 12, 2021 - 09:23 PDT
Investigating
We are investigating UI performance problems with the platform
Posted Apr 12, 2021 - 04:11 PDT
This incident affected: WebUI ( go.tradeshift.com ).