Platform unavailable
Incident Report for Tradeshift
Resolved
We’re back! We’re sorry for the disruption to your day
Posted Dec 14, 2018 - 08:06 PST
Investigating
We are currently investigating an issue with the platform WebUI
Posted Dec 14, 2018 - 07:57 PST
This incident affected: WebUI ( go.tradeshift.com ).