Degraded performance
Incident Report for Tradeshift
Resolved
The incident was resolved. Full availability is restored.
Posted Apr 16, 2018 - 07:12 PDT
Investigating
We are investigating performance problems with the platform
Posted Apr 16, 2018 - 07:08 PDT