Platform instability
Incident Report for Tradeshift
Resolved
This incident has been resolved.
Posted Dec 05, 2019 - 02:19 PST
Update
We are continuing to investigate this issue.
Posted Dec 05, 2019 - 02:19 PST
Investigating
We're investigating a problem with the platform
Posted Dec 05, 2019 - 01:46 PST
This incident affected: General availability.