Delayed processing of documents
Incident Report for Tradeshift
Resolved
This incident has been resolved.
Posted Mar 13, 2019 - 21:58 PDT
Investigating
We are investigating delays on document processing.

We apologize for the inconvenience.
Posted Mar 13, 2019 - 18:32 PDT
This incident affected: Tradeshift Go (getgo.tradeshift.com), WebUI ( go.tradeshift.com ), API ( api.tradeshift.com ), and Integration ( FTP/FTPS/SFTP ) ( si.tradeshift.com ).