Investigating delays in outbound emails from the system
Incident Report for Tradeshift
Resolved
This incident has been resolved.
Posted Apr 09, 2020 - 10:10 PDT
Identified
The issue has been identified as a problem with our downstream email provider. They are actively investigating and expect to resolve the issue soon.
Posted Apr 09, 2020 - 09:11 PDT
Investigating
We are investigating delays in outbound emails from the system including password resets and notifications.
Posted Apr 09, 2020 - 08:52 PDT
This incident affected: General availability and Tradeshift Go (getgo.tradeshift.com).