Platform unavailable
Incident Report for Tradeshift
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 04, 2019 - 04:28 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Jul 04, 2019 - 04:17 PDT
Investigating
We are currently investigating an issue with the platform
Posted 4 months ago. Jul 04, 2019 - 04:08 PDT
This incident affected: General availability and WebUI ( go.tradeshift.com ).