Network app issue
Incident Report for Tradeshift
Resolved
This incident has been resolved.
Posted 22 days ago. Oct 01, 2019 - 11:29 PDT
Identified
The relationship pages for connected companies in the network app can currently not be accessed. No business flows are affected - a fix is being implemented.
Posted 22 days ago. Oct 01, 2019 - 07:15 PDT
This incident affected: WebUI ( go.tradeshift.com ).