Platform unavailabe
Incident Report for Tradeshift
Resolved
The platform is available again and operating normally.
Posted Apr 20, 2018 - 07:11 PDT
Investigating
We are investigating problems in the Tradeshift Platform.
Posted Apr 20, 2018 - 06:59 PDT