Degraded performance
Incident Report for Tradeshift
Resolved
We’re back! We’re sorry for the disruption to your day
Posted about 1 month ago. May 07, 2019 - 16:19 PDT
Identified
The issue has been identified and the fix is being implemented
Posted about 1 month ago. May 07, 2019 - 07:26 PDT
Investigating
We are investigating performance problems with the platform
Posted about 1 month ago. May 07, 2019 - 06:04 PDT
This incident affected: Sandbox ( sandbox.tradeshift.com ).