Partial outage on Tradeshift Cards
Incident Report for Tradeshift
Resolved
This incident has been resolved.
Posted Jul 21, 2021 - 02:48 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2021 - 01:30 PDT
Investigating
We are currently investigating this issue.
Posted Jul 21, 2021 - 00:37 PDT
This incident affected: Tradeshift Go (getgo.tradeshift.com).