Currently we are deploying the platform and should be available again in a few minutes
Incident Report for Tradeshift
Resolved
Deploy is finished, thanks for your patience.
Posted Nov 25, 2016 - 18:46 PST
Investigating
We are currently investigating this issue.
Posted Nov 25, 2016 - 18:41 PST